re = /<\/?[\w]+([\s|\w]+\=\"[\s|\w|\.|\@|\%|\:|\/]*\")*>/m
str = '<HTML>
<HEAD>
<TITLE>Your Title Here</TITLE>
</HEAD>
<BODY BGCOLOR="FFFFFF">
<CENTER><IMG SRC="clouds.jpg" ALIGN="BOTTOM"> </CENTER>
<HR>
<a href="http://somegreatsite.com" name="asd" surname="">Link Name</a>
<a href="https://somesite.com" name="" surname="100%">support@yourcompany.com</a>
<P> This is a new paragraph!
<P> <B>This is a new paragraph!</B>
<BR> <B><I>This is a new sentence without a paragraph break, in bold italics.</I></B>
<HR>
</BODY>
</HTML>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end