#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1,2}\/optimized\/.+\.tif"
Local $sString = "{" & @CRLF & _
" $b$1/optimized/8757901_fpx.tif" & @CRLF & _
"}&cropN=0," & @CRLF & _
"0," & @CRLF & _
"14," & @CRLF & _
"1&anchor=0," & @CRLF & _
"0&layer=1&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$2/optimized/8757902_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.071," & @CRLF & _
"0&layer=2&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$4/optimized/8234544_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.143," & @CRLF & _
"0&layer=3&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$7/optimized/1111977_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.214," & @CRLF & _
"0&layer=4&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$0/optimized/8538460_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.286," & @CRLF & _
"0&layer=5&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$5/optimized/8234545_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.357," & @CRLF & _
"0&layer=6&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$3/optimized/1111973_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.429," & @CRLF & _
"0&layer=7&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$7/optimized/1252857_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.5," & @CRLF & _
"0&layer=8&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$8/optimized/1252858_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.571," & @CRLF & _
"0&layer=9&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$7/optimized/8234547_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.643," & @CRLF & _
"0&layer=10&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$0/optimized/8757900_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.714," & @CRLF & _
"0&layer=11&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$0/optimized/1111970_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.786," & @CRLF & _
"0&layer=12&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$1/optimized/1111971_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.857," & @CRLF & _
"0&layer=13&size=23," & @CRLF & _
"23&src=is{" & @CRLF & _
" $b$2/optimized/1111972_fpx.tif" & @CRLF & _
"}&anchor=0," & @CRLF & _
"0&posN=0.929," & @CRLF & _
"0&layer=14&op_sharpen=1&fmt=jpeg&qlt=90," & @CRLF & _
"0&hei=23') 322px 0 transparent;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")