import Foundation
let pattern = #"\d{1,2}\/optimized\/.+\.tif"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
$b$1/optimized/8757901_fpx.tif
}&cropN=0,
0,
14,
1&anchor=0,
0&layer=1&size=23,
23&src=is{
$b$2/optimized/8757902_fpx.tif
}&anchor=0,
0&posN=0.071,
0&layer=2&size=23,
23&src=is{
$b$4/optimized/8234544_fpx.tif
}&anchor=0,
0&posN=0.143,
0&layer=3&size=23,
23&src=is{
$b$7/optimized/1111977_fpx.tif
}&anchor=0,
0&posN=0.214,
0&layer=4&size=23,
23&src=is{
$b$0/optimized/8538460_fpx.tif
}&anchor=0,
0&posN=0.286,
0&layer=5&size=23,
23&src=is{
$b$5/optimized/8234545_fpx.tif
}&anchor=0,
0&posN=0.357,
0&layer=6&size=23,
23&src=is{
$b$3/optimized/1111973_fpx.tif
}&anchor=0,
0&posN=0.429,
0&layer=7&size=23,
23&src=is{
$b$7/optimized/1252857_fpx.tif
}&anchor=0,
0&posN=0.5,
0&layer=8&size=23,
23&src=is{
$b$8/optimized/1252858_fpx.tif
}&anchor=0,
0&posN=0.571,
0&layer=9&size=23,
23&src=is{
$b$7/optimized/8234547_fpx.tif
}&anchor=0,
0&posN=0.643,
0&layer=10&size=23,
23&src=is{
$b$0/optimized/8757900_fpx.tif
}&anchor=0,
0&posN=0.714,
0&layer=11&size=23,
23&src=is{
$b$0/optimized/1111970_fpx.tif
}&anchor=0,
0&posN=0.786,
0&layer=12&size=23,
23&src=is{
$b$1/optimized/1111971_fpx.tif
}&anchor=0,
0&posN=0.857,
0&layer=13&size=23,
23&src=is{
$b$2/optimized/1111972_fpx.tif
}&anchor=0,
0&posN=0.929,
0&layer=14&op_sharpen=1&fmt=jpeg&qlt=90,
0&hei=23') 322px 0 transparent;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)