# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{1,2}\/optimized\/.+\.tif"
test_str = ("{\n"
" $b$1/optimized/8757901_fpx.tif\n"
"}&cropN=0,\n"
"0,\n"
"14,\n"
"1&anchor=0,\n"
"0&layer=1&size=23,\n"
"23&src=is{\n"
" $b$2/optimized/8757902_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.071,\n"
"0&layer=2&size=23,\n"
"23&src=is{\n"
" $b$4/optimized/8234544_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.143,\n"
"0&layer=3&size=23,\n"
"23&src=is{\n"
" $b$7/optimized/1111977_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.214,\n"
"0&layer=4&size=23,\n"
"23&src=is{\n"
" $b$0/optimized/8538460_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.286,\n"
"0&layer=5&size=23,\n"
"23&src=is{\n"
" $b$5/optimized/8234545_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.357,\n"
"0&layer=6&size=23,\n"
"23&src=is{\n"
" $b$3/optimized/1111973_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.429,\n"
"0&layer=7&size=23,\n"
"23&src=is{\n"
" $b$7/optimized/1252857_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.5,\n"
"0&layer=8&size=23,\n"
"23&src=is{\n"
" $b$8/optimized/1252858_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.571,\n"
"0&layer=9&size=23,\n"
"23&src=is{\n"
" $b$7/optimized/8234547_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.643,\n"
"0&layer=10&size=23,\n"
"23&src=is{\n"
" $b$0/optimized/8757900_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.714,\n"
"0&layer=11&size=23,\n"
"23&src=is{\n"
" $b$0/optimized/1111970_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.786,\n"
"0&layer=12&size=23,\n"
"23&src=is{\n"
" $b$1/optimized/1111971_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.857,\n"
"0&layer=13&size=23,\n"
"23&src=is{\n"
" $b$2/optimized/1111972_fpx.tif\n"
"}&anchor=0,\n"
"0&posN=0.929,\n"
"0&layer=14&op_sharpen=1&fmt=jpeg&qlt=90,\n"
"0&hei=23') 322px 0 transparent;")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.