using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[,](?![^(]*\))";
string substitution = @"";
string input = @"&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}