import re
regex = re.compile(r"[,](?![^(]*\))")
test_str = "&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)