using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\(((?:[^()]|((?R))|(\((?:[^()]|(?3))*\)))*)\)\)";
string input = @"((We ((love | like)) this shirt(size xl)))
((We ((love | like)) this shirt(size (xl))))
((this((shirt|sweater))))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}