re = /\(\(((?:[^()]|((?R))|(\((?:[^()]|(?3))*\)))*)\)\)/
str = '((We ((love | like)) this shirt(size xl)))
((We ((love | like)) this shirt(size (xl))))
((this((shirt|sweater))))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end