$re = '/\(\(((?:[^()]|((?R))|(\((?:[^()]|(?3))*\)))*)\)\)/';
$str = '((We ((love | like)) this shirt(size xl)))
((We ((love | like)) this shirt(size (xl))))
((this((shirt|sweater))))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);