package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+7\s\([0-9]{3}\)\s[0-9]{3}\s-\s[0-9]{2}\s-\s[0-9]{2}$`)
var str = `+7 (000) 000 - 00 - 00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}