re = /^\+7\s\([0-9]{3}\)\s[0-9]{3}\s-\s[0-9]{2}\s-\s[0-9]{2}$/
str = '+7 (000) 000 - 00 - 00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end