const regex = /^\+7\s\([0-9]{3}\)\s[0-9]{3}\s-\s[0-9]{2}\s-\s[0-9]{2}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+7\\s\\([0-9]{3}\\)\\s[0-9]{3}\\s-\\s[0-9]{2}\\s-\\s[0-9]{2}$', 'g')
const str = `+7 (000) 000 - 00 - 00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}