using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=int|float|String|double|char|long)(?:\s+)([a-zA-Z_$][\w$]*)(?:\s*)|(?<=\G,)(?:\s*)([a-zA-Z_$][\w$]*)(?:\s*))(?=,|;|=)";
string input = @"int a= 100;
float b = 4.5;
long valid_name = 5435435345345
long longest = 453543543543;
char b = 'a';
String str = ""dfssffdsdfsd""
int d,f,g;
int a,f,frhg = 0;
String string = ""a,b,c,d,e,f""
int a = 45
long c;
int a, f, f = 5
int a , b , d = 6
String veryLongNameWhichWillProbablyTakeWholeLine
= dffd
int b,DG$%,df = 0 // here still is problem
float invalid name= 100.10;
int b^&& = 5
a = d;
String b b b b = ""dfdf""
double c - 12.454545645;
double d + 56;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}