const regex = /(?:(?<=int|float|String|double|char|long)(?:\s+)([a-zA-Z_$][\w$]*)(?:\s*)|(?<=\G,)(?:\s*)([a-zA-Z_$][\w$]*)(?:\s*))(?=,|;|=)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=int|float|String|double|char|long)(?:\\s+)([a-zA-Z_$][\\w$]*)(?:\\s*)|(?<=\\G,)(?:\\s*)([a-zA-Z_$][\\w$]*)(?:\\s*))(?=,|;|=)', 'g')
const str = `int a= 100;
float b = 4.5;
long valid_name = 5435435345345
long longest = 453543543543;
char b = 'a';
String str = "dfssffdsdfsd"
int d,f,g;
int a,f,frhg = 0;
String string = "a,b,c,d,e,f"
int a = 45
long c;
int a, f, f = 5
int a , b , d = 6
String veryLongNameWhichWillProbablyTakeWholeLine
= dffd
int b,DG\$%,df = 0 // here still is problem
float invalid name= 100.10;
int b^&& = 5
a = d;
String b b b b = "dfdf"
double c - 12.454545645;
double d + 56;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}