import Foundation
let pattern = #"(?:(?<=int|float|String|double|char|long)(?:\s+)([a-zA-Z_$][\w$]*)(?:\s*)|(?<=\G,)(?:\s*)([a-zA-Z_$][\w$]*)(?:\s*))(?=,|;|=)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
int a= 100;
float b = 4.5;
long valid_name = 5435435345345
long longest = 453543543543;
char b = 'a';
String str = "dfssffdsdfsd"
int d,f,g;
int a,f,frhg = 0;
String string = "a,b,c,d,e,f"
int a = 45
long c;
int a, f, f = 5
int a , b , d = 6
String veryLongNameWhichWillProbablyTakeWholeLine
= dffd
int b,DG$%,df = 0 // here still is problem
float invalid name= 100.10;
int b^&& = 5
a = d;
String b b b b = "dfdf"
double c - 12.454545645;
double d + 56;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)