const regex = new RegExp('(?:\\G(?!\\A)|START)\\s*\\K
(?!\\bEND\\b)
\\w+\\s+\\w+\\s+\\w+', 'g')
const str = `"words that don't matter START some words one some words two some words three END words that don't matter"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}