$re = '~(?:\G(?!\A)|START)\s*\K
(?!\bEND\b)
\w+\s+\w+\s+\w+~x';
$str = '"words that don\'t matter START some words one some words two some words three END words that don\'t matter"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);