re = /(?:\G(?!\A)|START)\s*\K
(?!\bEND\b)
\w+\s+\w+\s+\w+/x
str = '"words that don\'t matter START some words one some words two some words three END words that don\'t matter"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end