using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^temp(?:_\d+_?\d+_?\d+)?\.txt$";
string input = @"temp_2023_05_22.txt
temp.txt
temp_09_05_2022.txt
temp_22092023.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}