// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^temp(?:_\d+_?\d+_?\d+)?\.txt$").unwrap();
let string = "temp_2023_05_22.txt
temp.txt
temp_09_05_2022.txt
temp_22092023.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}