import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^temp(?:_\\d+_?\\d+_?\\d+)?\\.txt$";
final String string = "temp_2023_05_22.txt\n"
+ "temp.txt\n"
+ "temp_09_05_2022.txt\n"
+ "temp_22092023.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}