using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(([^>]*)srcset\=(?:\""|\')([^\""\']*)(?:\""|\'))?([^>]*)src=(?:\""|\')([^\""\']*)(?:\""|\')(([^>]*)srcset\=(?:\""|\')([^\""\']*)(?:\""|\'))?([^>]+)*>";
string input = @"<img width=""200"" height=""200"" sizes=""(max-width: 200px) 100vw, 200px"" srcset=""http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-100x100.png 100w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-32x32.png 32w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-64x64.png 64w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-96x96.png 96w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-128x128.png 128w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png 200w"" itemprop=""image"" title=""WordCamp Paris 2016 – Récap"" alt=""Lire l'article"" class=""attachment first thumbnail wp-post-image"" src=""http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png"">
<img src=""http://creativejuiz.fr/image.jpg"" width=""650"" height=""450"" srcset=""http://creativejuiz.fr/image2x.jpg 2x"" aria-hidden=""false"">
<img aria-serial=""lol"" src=""http://creativejuiz.fr/image.jpg"" width=""650"" height=""450"" srcset='http://creativejuiz.fr/image2x.jpg 2x' aria-hidden=""false"">
<img src=""http://creativejuiz.fr/test.jpg"" width=""650"" height=""450"" aria-hidden=""false"">
<img src=""http://creativejuiz.fr/test.jpg"">
<img src=""http://creativejuiz.fr/test.jpg"" width=""650"" height=""450"" srcset=""http://creativejuiz.fr/image2x.jpg 2x, http://creativejuiz.fr/image2x.jpg 3x, http://creativejuiz.fr/image-350x200.jpg 350w"" aria-hidden=""false"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}