# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img(([^>]*)srcset\=(?:\"|\')([^\"\']*)(?:\"|\'))?([^>]*)src=(?:\"|\')([^\"\']*)(?:\"|\')(([^>]*)srcset\=(?:\"|\')([^\"\']*)(?:\"|\'))?([^>]+)*>"
test_str = ("<img width=\"200\" height=\"200\" sizes=\"(max-width: 200px) 100vw, 200px\" srcset=\"http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-100x100.png 100w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-32x32.png 32w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-64x64.png 64w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-96x96.png 96w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-128x128.png 128w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png 200w\" itemprop=\"image\" title=\"WordCamp Paris 2016 – Récap\" alt=\"Lire l'article\" class=\"attachment first thumbnail wp-post-image\" src=\"http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png\">\n\n"
"<img src=\"http://creativejuiz.fr/image.jpg\" width=\"650\" height=\"450\" srcset=\"http://creativejuiz.fr/image2x.jpg 2x\" aria-hidden=\"false\">\n\n"
"<img aria-serial=\"lol\" src=\"http://creativejuiz.fr/image.jpg\" width=\"650\" height=\"450\" srcset='http://creativejuiz.fr/image2x.jpg 2x' aria-hidden=\"false\">\n\n"
"<img src=\"http://creativejuiz.fr/test.jpg\" width=\"650\" height=\"450\" aria-hidden=\"false\">\n\n"
"<img src=\"http://creativejuiz.fr/test.jpg\">\n\n"
"<img src=\"http://creativejuiz.fr/test.jpg\" width=\"650\" height=\"450\" srcset=\"http://creativejuiz.fr/image2x.jpg 2x, http://creativejuiz.fr/image2x.jpg 3x, http://creativejuiz.fr/image-350x200.jpg 350w\" aria-hidden=\"false\">")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.