import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img(([^>]*)srcset\\=(?:\\\"|\\')([^\\\"\\']*)(?:\\\"|\\'))?([^>]*)src=(?:\\\"|\\')([^\\\"\\']*)(?:\\\"|\\')(([^>]*)srcset\\=(?:\\\"|\\')([^\\\"\\']*)(?:\\\"|\\'))?([^>]+)*>";
final String string = "<img width=\"200\" height=\"200\" sizes=\"(max-width: 200px) 100vw, 200px\" srcset=\"http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-100x100.png 100w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-32x32.png 32w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-64x64.png 64w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-96x96.png 96w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016-128x128.png 128w, http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png 200w\" itemprop=\"image\" title=\"WordCamp Paris 2016 – Récap\" alt=\"Lire l'article\" class=\"attachment first thumbnail wp-post-image\" src=\"http://www.creativejuiz.fr/blog/wp-content/uploads/2016/02/wordcamp-paris-2016.png\">\n\n"
+ "<img src=\"http://creativejuiz.fr/image.jpg\" width=\"650\" height=\"450\" srcset=\"http://creativejuiz.fr/image2x.jpg 2x\" aria-hidden=\"false\">\n\n"
+ "<img aria-serial=\"lol\" src=\"http://creativejuiz.fr/image.jpg\" width=\"650\" height=\"450\" srcset='http://creativejuiz.fr/image2x.jpg 2x' aria-hidden=\"false\">\n\n"
+ "<img src=\"http://creativejuiz.fr/test.jpg\" width=\"650\" height=\"450\" aria-hidden=\"false\">\n\n"
+ "<img src=\"http://creativejuiz.fr/test.jpg\">\n\n"
+ "<img src=\"http://creativejuiz.fr/test.jpg\" width=\"650\" height=\"450\" srcset=\"http://creativejuiz.fr/image2x.jpg 2x, http://creativejuiz.fr/image2x.jpg 3x, http://creativejuiz.fr/image-350x200.jpg 350w\" aria-hidden=\"false\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}