using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)(\w+)(?=\s|$)";
string input = @"random
#random
?random
random?
ran?dom
rand#om
random#
XUY
ХУЙ ПИЗДА ДЖИГУРДА ЫВФХВЛБАДВА";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}