package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-z]`)
var str = `abc_def^gh[ij]k\lm-nop`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}