$re = '/[A-z]/';
$str = 'abc_def^gh[ij]k\\lm-nop';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);