const regex = /^(http|https):\/\/vk.com\/((club|public)[0-9]+|[a-z]+[_]*[a-z]+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http|https):\\\/\\\/vk.com\\\/((club|public)[0-9]+|[a-z]+[_]*[a-z]+)$', 'i')
const str = `http://vk.com/public123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}