$re = '/^(http|https):\/\/vk.com\/((club|public)[0-9]+|[a-z]+[_]*[a-z]+)$/i';
$str = 'http://vk.com/public123
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);