re = /^(http|https):\/\/vk.com\/((club|public)[0-9]+|[a-z]+[_]*[a-z]+)$/i
str = 'http://vk.com/public123
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end