# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<body\K/ class="new_class_attr"/;t' <<< "<body>
<div>(content)</div>
</body>"