use strict;
my $str = '<body>
<div>(content)</div>
</body>';
my $regex = qr~<body\K~p;
my $subst = ' class="new_class_attr"';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";