import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!666|000)[0-8][0-9\\_]{2}\\-(?!00)[0-9\\_]{2}\\-(?!0000)[0-9\\_]{4})*$";
final String string = "123-45-4891\n"
+ "098-18-6564\n"
+ "123-45-4848\n"
+ "009-95-8881\n"
+ "498-00-9859\n"
+ "908-78-0485\n"
+ "702-02-0202\n"
+ "001-84-0000\n"
+ "001-14-0004\n"
+ "987-65-4321\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}