$re = '/^((?!666|000)[0-8][0-9\_]{2}\-(?!00)[0-9\_]{2}\-(?!0000)[0-9\_]{4})*$/m';
$str = '123-45-4891
098-18-6564
123-45-4848
009-95-8881
498-00-9859
908-78-0485
702-02-0202
001-84-0000
001-14-0004
987-65-4321
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);