import re
regex = re.compile(r"^((?!666|000)[0-8][0-9\_]{2}\-(?!00)[0-9\_]{2}\-(?!0000)[0-9\_]{4})*$", flags=re.MULTILINE)
test_str = ("123-45-4891\n"
"098-18-6564\n"
"123-45-4848\n"
"009-95-8881\n"
"498-00-9859\n"
"908-78-0485\n"
"702-02-0202\n"
"001-84-0000\n"
"001-14-0004\n"
"987-65-4321\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")