# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!AND|OR)(?:\w+)/.$0./gm;t' <<< "salesforce AND (microsoft OR 451)"