const regex = /\b(?!AND|OR)(?:\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!AND|OR)(?:\\w+)', 'gm')
const str = `salesforce AND (microsoft OR 451)`;
const subst = `.$0.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);