import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*,\\w*).*";
final String string = "1,2,3,4,5,6,7,8,9,10\n"
+ ",,,,,,,,,\n"
+ "1,2,3,4,5,6,7,8,9,10\n"
+ "1,2,3,4,5,,,,,\n"
+ ",,,,,,,,,\n"
+ ",,,,,,,,,\n"
+ ",,,,,,,,,\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}