re = /(.*,\w*).*/m
str = '1,2,3,4,5,6,7,8,9,10
,,,,,,,,,
1,2,3,4,5,6,7,8,9,10
1,2,3,4,5,,,,,
,,,,,,,,,
,,,,,,,,,
,,,,,,,,,
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result