#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^-–—\s][^-–—]*?(?=\s*[-–—][^-–—\n]*$)"
Local $sString = "9500 anti-Xa IU/ml - 0,6 ml 5700 IU -" & @CRLF & _
"120 mg/ml – 0.165 ml -" & @CRLF & _
"300-300-300 IR/ml or IC/ml - 10 ml -" & @CRLF & _
"Fluocortolone-21-pivalate 1 mg/g, Lidocaine hydrochloride 20 mg/g - 15 g -"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")