re = /[^-–—\s][^-–—]*?(?=\s*[-–—][^-–—\n]*$)/m
str = '9500 anti-Xa IU/ml - 0,6 ml 5700 IU -
120 mg/ml – 0.165 ml -
300-300-300 IR/ml or IC/ml - 10 ml -
Fluocortolone-21-pivalate 1 mg/g, Lidocaine hydrochloride 20 mg/g - 15 g -'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end