import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^-–—\\s][^-–—]*?(?=\\s*[-–—][^-–—\\n]*$)";
final String string = "9500 anti-Xa IU/ml - 0,6 ml 5700 IU -\n"
+ "120 mg/ml – 0.165 ml -\n"
+ "300-300-300 IR/ml or IC/ml - 10 ml -\n"
+ "Fluocortolone-21-pivalate 1 mg/g, Lidocaine hydrochloride 20 mg/g - 15 g -";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}