package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):(-webkit-.*:.*|-moz-.*|-ms-.*){`)
var str = `input::-moz-placeholder { color: green;}
.css-4z0ic9:-ms-clear{display:none;}
::-webkit-scrollbar-track:hover{border-width:0.3125rem;background-color:rgba(255, 255, 255, 0.15625);}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}