$re = '/:(-webkit-.*:.*|-moz-.*|-ms-.*){/m';
$str = 'input::-moz-placeholder { color: green;}
.css-4z0ic9:-ms-clear{display:none;}
::-webkit-scrollbar-track:hover{border-width:0.3125rem;background-color:rgba(255, 255, 255, 0.15625);}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);