// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):(-webkit-.*:.*|-moz-.*|-ms-.*){").unwrap();
let string = "input::-moz-placeholder { color: green;}
.css-4z0ic9:-ms-clear{display:none;}
::-webkit-scrollbar-track:hover{border-width:0.3125rem;background-color:rgba(255, 255, 255, 0.15625);}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}