#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^#]+?(?:\.\d+)?(?=[. ;])"
Local $sString = "srvdata;172.24.154.210" & @CRLF & _
"srvnet;10.16.0.1" & @CRLF & _
"srvdata2 300" & @CRLF & _
"#srvdata3" & @CRLF & _
"srvdata3 #srvdata3" & @CRLF & _
"srvdata4.domain.com" & @CRLF & _
"srvdata.4.domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")