const regex = new RegExp('^[^#]+?(?:\\.\\d+)?(?=[. ;])', 'gm')
const str = `srvdata;172.24.154.210
srvnet;10.16.0.1
srvdata2 300
#srvdata3
srvdata3 #srvdata3
srvdata4.domain.com
srvdata.4.domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}