import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^#]+?(?:\\.\\d+)?(?=[. ;])";
final String string = "srvdata;172.24.154.210\n"
+ "srvnet;10.16.0.1\n"
+ "srvdata2 300\n"
+ "#srvdata3\n"
+ "srvdata3 #srvdata3\n"
+ "srvdata4.domain.com\n"
+ "srvdata.4.domain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}