package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0[1-9]|1[0-2])\/(0[1-9]|1\d|2\d|3[01])\/(19|20)\d{2}$`)
var str = `01/1/1901`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}