re = /^(0[1-9]|1[0-2])\/(0[1-9]|1\d|2\d|3[01])\/(19|20)\d{2}$/
str = '01/1/1901'
# Print the match result
str.match(re) do |match|
puts match.to_s
end